1. 概述 - SSLMS_Server_Help

1. 概述

管理系统包括两个组成部分：服务端和客户端。

服务端负责接收客户端的请求与数据库的数据交互以及业务逻辑的处理，客户端负责提供用户输入及输出的图形界面，将用户的请求转换为数据格式并向服务端发送处理请求，并接收服务端反馈的应答信息。

客户端必须以服务端的正常启动为存在条件，当服务端不可用时，客户端无法正常使用；

服务端程序部署在应用服务器上，并运行在Windows Server操作系统环境下，当操作系统启动时，服务端程序自动启动运行，并隐藏在桌面右下角。

LED控制器用于控制大货位输送口处LED的任务显示，LED控制器部署在服务端。

编写人员：

序号 | 姓名 | 公司
1 | 于彬彬 | 沈阳新松机器人自动化股份有限公司物流部

术语和缩写：

序号 | 缩写 | 描述
1 | SSLMS | 新松自动化物流管理系统
2 | SSWCS | 新松自动化监控调度系统
3 | SSECS | 新松自动化电器控制系统

文档列表：

序号 | 文档名称
1 | 《新松自动化物流管理系统（应用服务端）软件使用手册》
2 | 《新松自动化物流管理系统（应用客户端）软件使用手册》
3 | 《新松自动化物流管理系统（移动客户端）软件使用手册》


2. 服务端功能 - SSLMS_Server_Help

2. 服务端功能

双击桌面SSLMS-Server程序，启动服务端主界面如图1所示：

图1：服务端主界面


2.1. 服务列表 - SSLMS_Server_Help

2.1. 服务列表

界面上方的【服务列表】为所有服务端启动的服务，通过点击【启动服务】或【停止服务】按钮来启动或停止服务的运行；


2.2. 系统消息 - SSLMS_Server_Help

2.2. 系统消息

【系统消息】区显示服务端运行的业务处理反馈的错误和异常信息；


2.3. 保存消息 - SSLMS_Server_Help

2.3. 保存消息

l 点击【文件】-【保存消息】，弹出文件保存目录，选择文件目录，输入文件名，点击【保存】按钮，保存系统消息信息到文本文件；

l 点击【文件】-【清空消息】，清空系统消息信息；


2.4. 任务处理开关 - SSLMS_Server_Help

2.4. 任务处理开关

l 管理任务处理：监视并处理管理任务、控制指令，如：当管理任务完成时删除库存、删除指令等；

l 控制指令申请处理：监视并处理监控系统的申请指令，并根据申请指令自动生成任务指令；如：大货位和AGV入口条码扫描申请、异常完成至异常工位以及申请改道指令等；

l MES任务申请处理：监视MES任务申请，并解析MES任务生成SSLMS管理任务及指令；

l 通过点击相应的菜单选项，开启或关闭相应的任务处理开关；


2.5. 显示或退出系统 - SSLMS_Server_Help

2.5. 显示或退出系统

正常情况下，系统自动隐藏在后台运行，可通过鼠标右键点击桌面右下角小图标显示或隐藏或关闭系统，如图3：

图3：右键菜单

显示：当系统隐藏在后台时，可以点击该项，调出服务端软件界面，或双击图标显示；

隐藏：当系统显示时，可以点击该项，隐藏界面；

退出：停止所有服务端服务，关闭系统；